HostupCloudHostupCloud Status
Back to Incidents

PhonePe payment gateway timeout errors

MajorResolved
Started
Mar 30, 2026 at 08:27
Resolved
Mar 30, 2026 at 09:57
Duration
1h 30m
Affected Components
Billing PortalDegraded Performance
Payment Gateway (INR)Partial Outage

Timeline

Resolved
(22 days ago)

Payment processing via PhonePe is fully restored. All pending transactions have been processed successfully.

Monitoring
(22 days ago)

PhonePe has deployed a fix. We are monitoring transaction success rates.

Identified
(22 days ago)

PhonePe has confirmed an issue on their end causing timeout errors for some transactions. PayU and Cashfree gateways are unaffected.

Investigating
(22 days ago)

We are receiving reports of payment failures via PhonePe gateway. Investigating with the payment provider.

This incident was resolved on March 30, 2026 at 09:57.