HostupCloudHostupCloud Status
Back to Incidents

Delayed email notifications via Microsoft Graph API

MinorResolved
Started
Apr 4, 2026 at 08:27
Resolved
Apr 4, 2026 at 10:27
Duration
2h 0m
Affected Components
Email NotificationsDegraded Performance

Timeline

Resolved
(17 days ago)

Microsoft Graph API latency has returned to normal. All queued emails have been delivered. No emails were lost.

Identified
(17 days ago)

Microsoft Graph API is experiencing elevated latency. Emails are being queued and will be delivered once the upstream issue is resolved.

Investigating
(17 days ago)

Some users are reporting delayed receipt of transactional emails (magic links, invoices, ticket notifications).

This incident was resolved on April 4, 2026 at 10:27.