HostupCloudHostupCloud Status

Command Palette

Search for a command to run...

Back to Incidents

Platform-Wide Service Outage Affecting All Services

CriticalResolved
Started
Jul 24, 2026 at 14:25
Resolved
Jul 25, 2026 at 03:25
Duration
13h 0m
Affected Components
Affiliate PortalMajor Outage
Auth Provider (SSO)Major Outage
Bare Metal ServersMajor Outage
Billing PortalMajor Outage
CDN & Edge NetworkMajor Outage
Cloud ConsoleMajor Outage
DNSMajor Outage
Email NotificationsMajor Outage
Learning PlatformMajor Outage
Live ChatMajor Outage
Object Storage (S3)Major Outage
Payment Gateway (INR)Major Outage
Payment Gateway (International)Major Outage
Shared Hosting PanelMajor Outage
Support TicketsMajor Outage
Website & Landing PagesMajor Outage

Timeline

Resolved
(about 1 month ago)

Additional storage capacity has been provisioned and all platform services have been fully restored. We have verified that everything is operating normally as of 8:55 AM IST on July 25. We sincerely apologize for the extended disruption this caused to your experience. Our team is conducting a thorough review of our capacity monitoring and alerting processes to prevent a recurrence of this issue.

Identified
(about 1 month ago)

We have identified the cause of this outage. A storage capacity limit was reached in one of our data centers, which caused all platform services to become unavailable. Our team is actively working to add additional storage capacity to restore services as quickly as possible.

Investigating
(about 1 month ago)

Starting at approximately 7:55 PM IST on July 24, we began receiving reports that all platform services were unavailable. Our team was immediately alerted and began investigating the root cause. We apologize for the disruption and will provide updates as soon as possible.

This incident was resolved on July 25, 2026 at 03:25.